Has anyone got this to work in IFD deployment?

Aug 27, 2013 at 6:41 PM
Hi,

Firstly, I LOVE this tool! However, I can't for the life of me get it to work in our hosted IFD deployment.... I can successfully register the plugin on the server and all looks good when going back into CRM from the client. The extra WFlow Activities are there. But, when clicking on them to use them I get an error, the downloaded error text is:
Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Workflow contains an invalid custom activity.Detail: 
<OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
  <ErrorCode>-2147200968</ErrorCode>
  <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
  <Message>Workflow contains an invalid custom activity.</Message>
  <Timestamp>2013-08-27T18:35:19.0406579Z</Timestamp>
  <InnerFault i:nil="true" />
  <TraceText i:nil="true" />
</OrganizationServiceFault>
We are using Dynamics CRM 2011 UR7. The same version is used on both production and a self contained VM for development. It works without a hitch on dev.

Anyone got any ideas how to resolve?

I'm getting desperate!

Thanks

Jezza
Aug 27, 2013 at 9:49 PM
Solved it!

Although logged on to the CRM server as Deployment Admin when registering the plugin I was connecting to Dynamics using my own (System Admin) user id and as such could only register the Plugin in Sandbox mode. To resolve, I added the Deployment Admin as a user in CRM, connected the plug in registration tool to CRM using this same ID, and then registered the Plugin with Isolation Mode = None.

Hope that helps if anyone else is having the same issue